Advertisement

Author Topic: Camera go to next scene  (Read 1043 times)

0 Members and 1 Guest are viewing this topic.

Offline bootleg1

  • Members
  • *
Camera go to next scene
« on: 28 Feb 2015, 19:11:12 »
hey guys i could really use some help im using sqs format in a arma 2 oa mission im trying to get my intro to switch to a different camera position. here is what i have  and i cant get it to switch

showcinemaborder false;

["Afghanistan","2008"] spawn BIS_fnc_infoText;

titlecut [" ","BLACK IN",1]
_camera = "camera" camcreate [0,0,0]
_camera cameraeffect ["internal", "back"]

"filmGrain" ppEffectAdjust [0.09, 1, 1, 0.2, 1, false];
"filmGrain" ppEffectCommit 0;
"filmGrain" ppEffectEnable true;

_camera camPrepareTarget [87193.41,-48548.91,-21278.37];
_camera camPreparePos [8178.75,8659.57,14.88];
_camera camPrepareFOV 0.700;
_camera camCommitPrepared 0

? man1 distance man2 <=5 : goto "nextscene"
goto "loop"

#nextscene

;comment "19:01:58";
_camera camPrepareTarget [87804.89,-51733.90,662.24];
_camera camPreparePos [8312.39,8949.07,204.26];
_camera camPrepareFOV 0.700;
_camera camCommitPrepared 0

~40

_camera cameraeffect ["terminate","back"]
camdestroy _camera
end1=true;
exit;

Offline savedbygrace

  • Mission Depot
  • Administrator
  • *****
  • Be swift to hear...slow to speak...slow to wrath.
Re: Camera go to next scene
« Reply #1 on: 12 May 2015, 03:36:48 »
I'm not seeing your #loop label. Also, Have you tried placing the condition within parenthesis?
Code: [Select]
? (man1 distance man2 <=5) : goto "nextscene"

Offline ZacharyTub

  • Members
  • *
Re: Camera go to next scene
« Reply #2 on: 26 Oct 2018, 13:41:11 »
Do you have to set the #loop label to have the camera do this properly?
Hi!