Advertisement

Author Topic: clockHour/Minute Animation source not working  (Read 1340 times)

0 Members and 1 Guest are viewing this topic.

clockHour/Minute Animation source not working
« on: 23 Jan 2009, 00:43:29 »
Hi there,

Is there a special trick to getting a working "clock" in my new AH-64A? I've ported the old OPF model and added a tilting sensor cluster and moveable aileron (I plan to upgrade to the AH-64D with the mast mounted radar and more Hellfires), but from the pilot LOD, the Clock just won't work! In Bulldozer I can select the class but nothing happens when I animate. All the the other controls work fine BTW.

The animation works if I use any other animation source (e.g. rpm) but when I use clockHour or clockMinute, I can't get the damn needles to move.

My Model and Skeleton inherits from Vehicle and Helicopter and as far as I can tell the clock hands should be moving!

Has anyone else got the clocks to move using clockMinute and clockHour?

I'd be grateful for any assistance  :)

Cheers,
DAM
There are 10 types of people in the world. Those who understand binary, and those who don't

Offline Planck

  • Honoured
  • Former Staff
  • ****
  • I'm never wrong ....I'm just not always right !
Re: clockHour/Minute Animation source not working
« Reply #1 on: 23 Jan 2009, 02:29:25 »
I think if you leave them and come back in five minutes you will probably see they have moved.


Planck
I know a little about a lot, and a lot about a little.

Re: clockHour/Minute Animation source not working
« Reply #2 on: 23 Jan 2009, 02:42:49 »
Thanks Planck... unfortunately after much testing (and waiting), I have found that the following is true
Code: [Select]
probably != actually && should != does && can != willI'm sure there are many combinations I haven't tried yet  :)
There are 10 types of people in the world. Those who understand binary, and those who don't

Offline Planck

  • Honoured
  • Former Staff
  • ****
  • I'm never wrong ....I'm just not always right !
Re: clockHour/Minute Animation source not working
« Reply #3 on: 23 Jan 2009, 03:03:37 »
If I recall correctly I also found that I could not cause the clock hands to move in buldozer using the mouse wheel.

Every other instrument seemed to work fine, but not the clocks.

Then I noticed that if I went away and did something else and came back the hands had moved on slightly with the passage of time.
In some cases it went backwards which meant I had to reverse the axis points.

Only other reason to cause it not to work would maybe be your model.cfg and/or config.cpp.

Unless of course you forgot to wind them up.   :blink:


Planck
I know a little about a lot, and a lot about a little.

Offline Gnat

  • Addons Depot
  • Moderator
  • *****
  • I Bite!
    • Gnats
Re: clockHour/Minute Animation source not working
« Reply #4 on: 23 Jan 2009, 12:16:23 »
Its already in the Helicopter model animation definition .....
Code: [Select]
class WatchHour: Rotation
{
source="clockHour";
selection="hodinova";
axis="osa_time";
memory="false";
angle1="rad -360";
};
class WatchHour2: WatchHour
{
selection="hodinova2";
axis="osa_time2";
};
class WatchMinute: Rotation
{
source="clockMinute";
selection="minutova";
axis="osa_time";
memory="false";
angle1="rad -360";
};
class WatchMinute2: WatchMinute
{
selection="minutova2";
axis="osa_time2";
};

So if your still stuck, change your named sections and axis etc to those above to mimic.
Also, make sure you have no over-lapping named sections and animations to the clock bits that may be locking out the engines attempts to move your hands.
« Last Edit: 23 Jan 2009, 23:30:05 by bedges »

Re: clockHour/Minute Animation source not working
« Reply #5 on: 23 Jan 2009, 16:55:28 »
Looks like Planck was right (again).

The dials do move, but you can't use the mouse wheel or [ ] to animate them in Bulldozer. I did however notice the Environment settings allow you to change the TOD and the hands spin round like crazy  :)

@Gnat: Thanks, I used that same config in my new class so I could tweak and play with all the options.

Thanks for your help :good:
There are 10 types of people in the world. Those who understand binary, and those who don't

Offline Gnat

  • Addons Depot
  • Moderator
  • *****
  • I Bite!
    • Gnats
Re: clockHour/Minute Animation source not working
« Reply #6 on: 24 Jan 2009, 11:22:57 »
yep, same as "time" source, the mouse in O2 won't change it.