Advertisement

Author Topic: Motorcycle Config  (Read 1815 times)

0 Members and 1 Guest are viewing this topic.

Offline dcb

  • Members
  • *
Motorcycle Config
« on: 16 Jan 2009, 19:30:23 »
Greetz from the CAF Clan :),

I've been recently working on a Superbike (knockoff of a Suzuki) for the CityLife Mod in ArmA. I'm totally new to configging so I have hit numerous bumps along the road, the model is complete, but the config needs help. Here it is below:


Code: [Select]
class CfgPatches
{
class CAWheeled3
{
units[] = {};
weapons[] = {};
requiredVersion = 0.10;
requiredAddons[] = {CAWheeled};
};
};
class CfgSkeletons
{
class Vehicle;
class CL_Superbike: Vehicle
{
skeletonInherit="Vehicle";
skeletonBones[]=
{
"volant",
"",
"ukaz_rychlo",
"volant",
"ukaz_rychlo2",
"volant",
"ukaz_rpm",
"volant",
"pravy predni tlumic nerot",
"",
"pravy predni tlumic",
"volant",
"pravy zadni tlumic",
"",
"Pravy predni",
"Pravy predni tlumic",
"Pravy zadni",
"pravy zadni tlumic",
"OtocVez",
"",
"OtocHlaven",
"OtocVez",
"stojanek",
"",
"WheelStandFront",
"Pravy predni tlumic",
"WheelStandBack",
"Pravy zadni tlumic"
};
};
};
class CfgModels
{
class Vehicle;
class CL_Superbike: Vehicle
{
sectionsInherit="Vehicle";
sections[]=
{
"ammo",
"sklo predni p",
"sklo predni l",
"zadni svetlo",
"brzdove svetlo",
"spz",
"zbytek",
"karoserie",
"palivo",
"Pravy predni",
"Pravy zadni"
};
skeletonName="CL_Superbike";
class Animations
{
class IndicatorSpeed
{
type="rotation";
source="speed";
selection="ukaz_rychlo";
axis="osa_rychlo";
memory="false";
animPeriod=0;
minValue=0;
maxValue="140 / 3.6";
angle0=0;
angle1="rad 280";
};
class IndicatorSpeed2
{
type="rotation";
source="speed";
selection="ukaz_rychlo2";
axis="osa_rychlo2";
memory="false";
animPeriod=0;
minValue=0;
maxValue=16.670000;
angle0=0;
angle1="rad -240";
};
class IndicatorRPM
{
type="rotation";
source="rpm";
selection="ukaz_rpm";
axis="osa_rpm";
memory="false";
animPeriod=0;
minValue=0;
maxValue=1;
angle0=0;
angle1="rad -340";
};
class DrivingWheel
{
type="rotation";
source="drivingWheel";
selection="volant";
axis="volant osa";
memory="true";
animPeriod=0;
minValue=-1;
maxValue=1;
angle0=18;
angle1=-18;
};
class Support
{
type="rotationX";
source="support";
selection="stojanek";
axis="osa stojanku";
memory="true";
animPeriod=0;
angle0="rad 90";
angle1=0;
};
class WheelStandFront
{
type="translationY";
source="support";
selection="WheelStandFront";
minValue=0.000000;
maxValue=0.055000;
};
class WheelStandBack
{
type="translationY";
source="support";
selection="WheelStandBack";
minValue=0.000000;
maxValue=0.055000;
};
class FrontWheel
{
type="rotationX";
source="wheel";
selection="Pravy predni";
axis="Pravy predni osa";
memory="true";
animPeriod=0;
sourceAddress="loop";
minValue=0;
maxValue=1;
angle0=0;
angle1="rad -360";
};
class BackWheel: FrontWheel
{
selection="Pravy zadni";
axis="Pravy zadni osa";
};
class FrontWheelDamperVirt
{
type="translationY";
source="FrontDamper";
selection="pravy predni tlumic nerot";
axis="";
animPeriod=0;
minValue=-1000;
maxValue=1000;
};
class FrontWheelDamper: FrontWheelDamperVirt
{
source="FrontDamper";
selection="pravy predni tlumic";
};
class BackWheelDamper: FrontWheelDamperVirt
{
source="BackDamper";
selection="pravy zadni tlumic";
};
};
};
};
class CfgVehicles
{
class Land;
class LandVehicle : Land
{
class NewTurret;
};
class Car: LandVehicle
{
class Damage;
};
class CL_Superbike: LandVehicle
{
/* speechSingular[] = {"KB_Motorbike", db+0, 1};
speechPlural[] = {"KB_Motorbikes", db+0, 1};*/
alphaTracks = 0.1;
textureTrackWheel = 1;
class Exhausts
{
class Exhaust1
{
position = "vyfuk start";
direction = "vyfuk konec";
effect = "ExhaustsEffect";
};
};
dammageHalf[]= {};
dammageFull[]= {};
canfloat = 0;
transportSoldier = 1;
driverAction = "Bike_Driver";
cargoAction[]= {"Bike_Cargo"};
ejectDeadDriver = true;
ejectDeadCargo = true;

hideWeaponsDriver = false;
hideWeaponsCargo = false;

damperSize = 0.2;
damperForce = 1; // larger number more stiffness dampers
damperDamping = 3; // larger number less movement in dampers

// provide names dampers
class AnimationSources
{
class FrontDamper
{
source="damper";
selection="pravy predni tlumic nerot"; // landcontact selection name
};
class BackDamper
{
source="damper";
selection="pravy zadni tlumic"; // landcontact selection name
};
};
soundEngine[] = {"bike\sound\bike3.ogg", db0, 1.0};
soundGetOut[] = {"", db-50, 1};

class DestructionEffects
{
class Light1
{
simulation = "light";
type = "ObjectDestructionLight";
position = "destructionEffect1";

intensity = 0.001;
interval = 1;
lifeTime = 3;
};
class Sound
{
simulation = "sound";
type = "Fire";
position = "destructionEffect1";

intensity = 1;
interval = 1;
lifeTime = 3;
};
class Fire1
{
  simulation = "particles";
  type = "BarelDestructionFire";
  position = "destructionEffect1";

  intensity = 0.15;
  interval = 1;
  lifeTime = 3;
};
class Smoke1
{
  simulation = "particles";
  type = "BarelDestructionSmoke";
  position = "destructionEffect1";

  intensity = 0.15;
  interval = 1;
  lifeTime = 3.2;
};
};
};
};

Now my problem is, I have that plus a CrewAnimations.hpp file I put into the model's folder, and when I pack it up into a PBO it doesent show up ingame :(
So what I am asking for is just a bit of help, guidance to show me what I am doing wrong, and possibly if anyone has the spare time, could show me how to get a Turbo Script going in there as the top speed on land vehicles is nowhere near how fast I want this baby to go :D

Offline DeanosBeano

  • Addons Depot Staff
  • *****
  • SirDeanosbeano bstowed on me by sui ;)
    • Fraghaus
Re: Motorcycle Config
« Reply #1 on: 16 Jan 2009, 21:20:11 »
 jesus mate you are way off :).
 Now are you just trying  to take a model from ofp and slap it in arma ?
 please give more details and maybe a picture of the bike so more help can be provided .
 
 your first pointers are that you have no path to your model :  Model = "\folder\model\"; and second is the whole config is an abortion ;).
   come back with some clear info about the bike , what it looks like, what then named selections are in the lods and what the axis points are called and it may start to unravel .

 
I love ofp

Offline Planck

  • Honoured
  • Former Staff
  • ****
  • I'm never wrong ....I'm just not always right !
Re: Motorcycle Config
« Reply #2 on: 16 Jan 2009, 22:02:19 »
Another salient point is that the CfgSkeletons and CfgModels sections should be in a separate file called model.cfg by default.

This file is then placed in the folder along with a working config.cpp and the p3d file and its associated textures and any other files needed, the addon is then binarized to incorporate the info in the model.cfg file into the p3d file itself.

Having the CfgSkeletons and CfgModels sections in the main config can result in the model file not working as intended as far as animations and special effects go.


Planck
I know a little about a lot, and a lot about a little.

Offline Gnat

  • Addons Depot
  • Moderator
  • *****
  • I Bite!
    • Gnats
Re: Motorcycle Config
« Reply #3 on: 17 Jan 2009, 04:30:26 »
And all those named sections in the Skeleton would have to match the needed sections in YOUR bike
Just copying the config from BIS for motorbike won't make it work straight away.

For more help, your need to describe what you have done there.

Offline dcb

  • Members
  • *
Re: Motorcycle Config
« Reply #4 on: 17 Jan 2009, 05:36:41 »
Here is the bike :)


Offline DeanosBeano

  • Addons Depot Staff
  • *****
  • SirDeanosbeano bstowed on me by sui ;)
    • Fraghaus
Re: Motorcycle Config
« Reply #5 on: 17 Jan 2009, 10:56:03 »
ok you have a Bike shape object :).
 If i assume you have not already done the following steps its easier probably :) ,so here goes.

1 Download Bis tool pack and install.
 this will create a P: drive .
 2 Place the folder containg your motobike on the P : drive.
 3 Download the Bis Mlods and also place on your P :drive
4 open your bike and the bis motorbike .
 5 copy the geometry lod and memory lod from the Bis Motorbike and paste them in yout motorbike.
6 in the geometry lod make sure the appropiate component is in the correct poistion to suite your bike, you will have a yellow outline showing when you are in the geo lod, giving you guidance as to where they should be, name your components in your other lods 0.00 pilot view etc in tune with the names in the bis lods .
7. do the same for your memory points.
8 do as plank says and create a model.cfg and place your skeleton and model sections from your cpp and place them in the new model.cfg.
9. ino2 select the options to load model.cfg and view anims
10 open bulldozer and check your animations.
11 when you do this come back with your error reports  and we can sort out whats wrong with your model.cfg :)




 
« Last Edit: 17 Jan 2009, 11:04:39 by DeanosBeano »
I love ofp

Offline kju

  • Members
  • *
    • PvPScene - The ArmA II multiplayer community
Re: Motorcycle Config
« Reply #6 on: 17 Jan 2009, 14:51:06 »
Get the bike of ACE (or another other installed) and check their config and model.

Offline DeanosBeano

  • Addons Depot Staff
  • *****
  • SirDeanosbeano bstowed on me by sui ;)
    • Fraghaus
Re: Motorcycle Config
« Reply #7 on: 17 Jan 2009, 15:33:21 »
 and learn absolutely nothing .
 or do what i suggested and we shall get your bike working like bis bike and then we will step by step TAG all your selections and animations etc and you will learn how to Teach others and so the community will grow ;).

#EDIT: don't quote the entire previous post you're replying to..     h-
« Last Edit: 17 Jan 2009, 16:35:19 by h- »
I love ofp

Offline kju

  • Members
  • *
    • PvPScene - The ArmA II multiplayer community
Re: Motorcycle Config
« Reply #8 on: 17 Jan 2009, 17:15:10 »
well its not either or instead its both.  :good:

(i didnt mean he should use/take their model / config, yet learn from it)

Offline DeanosBeano

  • Addons Depot Staff
  • *****
  • SirDeanosbeano bstowed on me by sui ;)
    • Fraghaus
Re: Motorcycle Config
« Reply #9 on: 17 Jan 2009, 18:16:16 »
agreed mate,
 my thinking is that the best question that can be asked ,in these situations is "I have set up my model exactly as Bis ,but its not working " .
 this way anybody answering can see what is wrong because we all play from level field ;).
    second benefit from this is that i have always said, learn from something you know is 100% conformed to Bis set up and then change ,step by step, this way you can understand both what it is you are changing and also what that change has done ;).
 one day i shall do it this way too ;).

I love ofp

Offline dcb

  • Members
  • *
Re: Motorcycle Config
« Reply #10 on: 17 Jan 2009, 18:28:25 »
Hi Deanos !

 :D I'm up to Step 3 on your list and still working, but I have a bulldozer problem at the moment  :weeping:

When I open up my bulldozer it says "Shaders not valid (mismatch of exe and data?)" any clue on how to fix this annoying problem because atm I'm stuck packing it into a PBO and testing it ingame.

Thanks,
dcb
« Last Edit: 17 Jan 2009, 18:30:07 by dcb »

Offline Planck

  • Honoured
  • Former Staff
  • ****
  • I'm never wrong ....I'm just not always right !
Re: Motorcycle Config
« Reply #11 on: 17 Jan 2009, 19:22:40 »
As you are probably using the ArmA.exe from the game as your buldozer it will transpire that the bin folder in your P:\ drive will not have the shader files to match the ArmA.exe you are using.

If you extract a copy of the bin folder (Dta\bin) from your game and replace the bin folder in your P:\ drive with that one everything will probably work as expected........maybe.   ::)


Planck
I know a little about a lot, and a lot about a little.