Welcome, Guest Friday 25th April 2014, 00:51:41
   Home   Help Search Login Register  

OFPEC Forum

Author Topic: Dedicated Server Rearm,Repair, and Reload  (Read 321 times)
0 Members and 1 Guest are viewing this topic.
sardaukar17
*
Offline Offline


« on: 02 Oct 2009, 00:50:46 »

Has anyone run into this problem?

When my map is tested on Preview and when I host it on my computer I can use the Warfare Building "USMC Service Station" To rearm, Refuel, and Reload vehicles. When it is run on a dedicated server however, none of the Ammo crates, service stations, and any other buildings or ammo boxes supply vehicles any more.. Anyone know why that is and/or a way to fix it?

Right now I am back where I started on creating a new service station.. or (FARP)  Wink
Logged
kju
*
Offline Offline



WWW
« Reply #1 on: 03 Oct 2009, 08:43:28 »

Locality bug in arma. Only works for local vehicles.
You have to make the unit/object local to be able to issue the command.
Logged

sardaukar17
*
Offline Offline


« Reply #2 on: 04 Oct 2009, 17:17:39 »

In order to make each of those supply objects local for each client would I have to run a creation script for each object that would then run on each client? or is there an easier way?

Logged
tcp
*
Offline Offline


WWW
« Reply #3 on: 04 Oct 2009, 18:18:42 »

Create a marker where you want the service point called FARP1mrk
In init.sqf:
FARP1 = "USMC_WarfareBVehicleServicePoint" createVehicleLocal getMarkerPos "FARP1mrk";

It will locally create one on every client and the server.
Logged
sardaukar17
*
Offline Offline


« Reply #4 on: 05 Oct 2009, 03:52:01 »

That did end up working. Thank you!
« Last Edit: 05 Oct 2009, 09:38:02 by sardaukar17 » Logged
Pages: [1]   Go Up
  Send this topicPrint  
 
Jump to: