Editors Depot - Mission Editing and Scripting => Arma2 - Editing/Scripting General => Topic started by: Hawkins on 26 Aug 2014, 23:19:17

Title: The 'skill and 'setskill' commands - cannot define overall skill [SOLVED]
Post by: Hawkins on 26 Aug 2014, 23:19:17
Hello peeps! Been a while since I have done anything regarding missions, so this might be just my poor memory or just lack of skill...

I've been accustomed to using the setskill command to set the skill of enemy units in MP missions. I have a Param in my description.ext which has three possible options for the skillset of the enemy units. The selected skill level is then set for the units in a trigger that covers the AO where the enemy units are, like so:

Code: [Select]
{_x setskill Param1} foreach list easttrig;
Where Param1 is the skill number from 0-1. When I debug the mission to check the skill of the enemy units using the skill command, like so:
Code: [Select]
skill testloon... it does not return the value of the Param1 but returns the value that was set for the unit in the skill slider when it was placed on the map. I have also tested it by setting the skill directly with:
Code: [Select]
{_x setskill 0.5} foreach list easttrig;
Does not work... Furthermore, I read that the command is now a set on 'subskills', and noticed it has a 'general' value. Using it like that did not either return the value I wanted:
Code: [Select]
{_x setskill ["general",0.5]} foreach list easttrig;
Same thing with the setUnitAbility command, using the skill command still returns the value of the skill slider preset when the unit was placed. While I really like the new way of setting separate sub-skills for the enemy units, would be awesome to set the 'general' skill for the units as well. Is it even possible anymore? What skill level does the skill command return?

Apologies if this did not make sense; please ask me to elaborate if needed.
Title: Re: The 'skill and 'setskill' commands - cannot define overall skill
Post by: Hawkins on 27 Aug 2014, 07:00:10
Well, for some strange reason, now it works! I have no idea what I did to fix it, but it works, the same way as it used to. Sorry for bothering you all :good: :clap:
Title: Re: The 'skill and 'setskill' commands - cannot define overall skill [SOLVED]
Post by: savedbygrace on 29 Aug 2014, 00:22:42
No bother. I opened up the editor and began testing the setskill command, myself yesterday but the command worked fine. I had some stuff pop up before I could test the other commands though. Sorry I wasn't quick enough.