Advertisement

Author Topic: end does not work  (Read 322 times)

0 Members and 1 Guest are viewing this topic.

Offline joske

  • Members
  • *
end does not work
« on: 08 May 2010, 15:59:13 »
Ok a few days ago i started making a mission, and sadly i now have stumbled upon a problem i hope somebody in here can help me with.
Ok so this mission of me revolves around escorting a jeep filled with guns trough an enemy occupied town, so i want the game to end when the jeep gets destroyed.
So first made a trigger with ! (alive car1) in the condition box and lose in the end-dropdown-menu , so i try it and it ends. then i tried to put some time between the destruction of the jeep and the end, so i added 10 in all the countdown boxes, and suddenly it does not end anymore, i even tried to make a trigger that would be activated by anyone and just put end1 or any other end in the dropdown box and i just wouldnt end.
now then i tried to port over the mission to another file and thus merged the mission with a new save-file and ported over all the scripts, and i managed to get the primary ending work, but then it didnt want to work anymore again.
now i only have the win-end in place, and when i tried to port it over again it wouldnt work anymore.
anyone has an idea what is causing this problem and how i can solve it?
For the record i am running Arma with patch 1.14 and ECS mod and some smaller addons like editor updates, but i have already made several missions with this combo and i havent got any problems with it back then.

Offline savedbygrace

  • Mission Depot
  • Administrator
  • *****
  • Be swift to hear...slow to speak...slow to wrath.
Re: end does not work
« Reply #1 on: 16 Jun 2010, 13:15:46 »
Looks like you have the condition correct but without knowing more details that involve that trigger or other end conditions, its difficult to see where you're having problems.

Offline joske

  • Members
  • *
Re: end does not work
« Reply #2 on: 23 Jun 2010, 11:27:22 »
well the ending triggers are very simple most of the time, they only have one condition most of the time such as the !(alive car1) one or just having a certain unit present (connecting the trigger to the group leader, using the group button) and then just selecting the end in the dropdown menu.
anyways i stopped working on that mission a while ago, i sometimes play it again together with some other missions i made/ adapted if i want some gameplay and dont want to play some other game.
also about the problem itself i think its a problem with the game itself or with my computer, because even when i tested a simple trigger with a certain side (say independent) on present and in the dropdown menu a certain end in certain cases it just doesnt end when i run into it with a racs soldier while in other cases it does end.

Offline savedbygrace

  • Mission Depot
  • Administrator
  • *****
  • Be swift to hear...slow to speak...slow to wrath.
Re: end does not work
« Reply #3 on: 24 Jun 2010, 04:21:23 »
Well, sorry for the delayed response then. I hope we haven't discouraged you in anyway. If you would like to  attach the mission, I can try it out on my computer and see if it works. That way we can eliminate whether it is PC or game related. I can even open it up and see if you might be accidentally overlooking something.

Offline haroon1992

  • Members
  • *
  • My life is hopeless...
Re: end does not work
« Reply #4 on: 24 Jun 2010, 17:57:12 »
Its sometimes like that.
I encountered this issue once.

If you put an ending trigger with a delay, it will no longer ends...

For this  you have to do the following to overcome the problem
(But even this sometimes don't work,if i remember correctly)

Put the ENDING trigger and have its condition like this
Type : End1
condition : loseend

now put another trigger which checks whether the jeep has destroyed
condition : !(alive jeepy1)
on act : loseend=TRUE

REMEMBER : put the delay in the SECOND trigger (NOT the ending trigger!!!)

Another way :
create a script that checks whether the jeep is dead.
in .sqs

Run the script at start up.
loseend.sqs
Code: [Select]
#loop

;goto to delay loop if jeep is history
? not (alive jeepy1) : goto "waitabit"
~1

goto "loop"

#waitabit

;put any desired delay value in '15'
~15

loseend=TRUE
exit
in .sqf

loseend.sqf
Code: [Select]
while {alive jeepy1} do
{
sleep 2;
};
//put any desired delay instead of 15
sleep 15;
loseend=TRUE;

hope this solves your issue,
Regards,
Haroon1992
Very busy with life, business, and other stuff. Away from OFP for months. Not sure if I could get back onto it. :(