Welcome, Guest Wednesday 23rd April 2014, 15:22:42
   Home   Help Search Login Register  

OFPEC Forum

Author Topic: Firing during animations  (Read 209 times)
0 Members and 1 Guest are viewing this topic.
Zipper5
Missions Depot Staff
*****
Offline Offline



« on: 17 Dec 2009, 20:53:00 »

Hey guys.

I've run into a problem. I've got a point in a mission that I'm making where a character takes out his Makarov and shoots an injured man. To make this look better, I've used an animation which was used in the official campaign. However, I can't seem to get the character to actually fire the Makarov. I've seen it done in movies and missions before, having the AI fire their weapon while performing an animation. I just can't seem to get it to work.

Currently, I've tried both fire and doFire, as well as making sure the weapon is selected by using selectWeapon, but to no avail. If anyone has any idea of how to get them to fire while performing the animation, I'll be very grateful.

Thanks. Smiley
Logged
DeanosBeano
Addons Depot Staff
*****
Offline Offline


SirDeanosbeano bstowed on me by sui ;)


WWW
« Reply #1 on: 18 Dec 2009, 18:05:32 »

 it maybe that the animation your using has some parameters defined in its config .
 check the animation name in the Allinone config , your looking for

 disableWeapons = 1;
 disableWeaponsLong = 1;

     just my guess , it maybe also muzzle and mode selection in the way your asking it to fire, but i think you know that side of things well ?

 db
Logged

I love ofp
Pages: [1]   Go Up
  Send this topicPrint  
 
Jump to: