Advertisement

Author Topic: Spawning motorcycle problem  (Read 400 times)

0 Members and 1 Guest are viewing this topic.

Offline Trexian

  • Members
  • *
Spawning motorcycle problem
« on: 23 Aug 2009, 05:24:13 »
Ok.  I know how to spawn a motorcycle. :)  But, in A2, it won't spawn and the rpt has the following error:
Quote
Cannot create non-ai vehicle T650_Gue,

Likewise with the _Civ and _Ins.  The only thing that works is the M1030, which kinda makes sense since I'm playing as USMC.

But, has anyone else encountered this?  I thought it might be a side-center issue, but I even placed a civilian on the map (there's already USMC and Russian forces on the map) to no avail.

My spawn line couldn't be simpler (the _posX/_posY are verified with hints):

Code: [Select]
_cycle1 = "T650_Civ" createVehicle [_posX, _posY, 0];
The rpt is otherwise devoid of errors.  Like... literally.  Other than the CBA init stuff being written, that's the only line.

I'm sure there's something simple I'm overlooking.  (All the variables are made private, the position is valid, all my usual mistakes have been checked....) :D
Sic semper tyrannosauro.

Offline DeanosBeano

  • Addons Depot Staff
  • *****
  • SirDeanosbeano bstowed on me by sui ;)
    • Fraghaus
Re: Spawning motorcycle problem
« Reply #1 on: 23 Aug 2009, 09:44:35 »

 the class for the bikes are
        TT650_Civ,
        TT650_Ins,
        TT650_Gue

  i think your just missing a T  so your right its something simple :). i checked and there scope = 2 . so they are available to spawn .
  the other reason this can happen if they are Scope =1 , which is usually applied to the _base classes.

 
I love ofp

Offline Trexian

  • Members
  • *
Re: Spawning motorcycle problem
« Reply #2 on: 24 Aug 2009, 01:55:38 »
Faaaaaaak.

I suck. :D

Classic copy/paste problem, and I didn't double check that.

Although, it seems like thats a strange error, in that - and I'm sure you'll believe this - I've gotten the name wrong before, and it seems like the error report is different.  Something like, "Could not find...." or ".... doesn't exist."

Thanks, mate.  (Wish I could delete this thread.) ;)
Sic semper tyrannosauro.