Advertisement

Author Topic: ACM Module intensity problem  (Read 614 times)

0 Members and 1 Guest are viewing this topic.

Offline nominesine

  • Former Staff
  • ****
  • I'm NOT back!
    • The IKB Forum
ACM Module intensity problem
« on: 14 Aug 2009, 13:16:08 »
Code: [Select]
[0.0, BIS_ACM] call BIS_ACM_setIntensityFunc;
According to the Biki the quoted code will: "in effect pause the ACM". This much I've figured out and to switch it back on again I must use

Code: [Select]
[1.0, BIS_ACM] call BIS_ACM_setIntensityFunc;
or any scalar number greater than 0. But my limited testing (three hours) implies that it doesn't work more than once. I wan't a mission that starts with no intensity and then gradually builds up towards heavy fighting around the player. No matter how high I raise the intensity value, no ambient units show up in game if the ACM has been paused once.

If I do it the other way around (start with a high intensity number) I can force it into hiatus by setting intensity to 0. Hence I assume the syntax is correct. But why can't I start with low intensity and gradually raise it during the mission?
« Last Edit: 14 Aug 2009, 13:22:25 by nominesine »
OFPEC | Intel Depot
RETARDED Ooops... Retired!

Offline JamesF1

  • Editors Depot Staff
  • *****
    • JamesBurgess.co.uk
Re: ACM Module intensity problem
« Reply #1 on: 15 Aug 2009, 21:55:42 »
Meant to reply to this the other day, but got sidetracked!  I wonder if setting the intensity to a stupidly small number (e.g. 0.000001), rather than to 0, would work to effectively 'pause' the ACM?

Offline nominesine

  • Former Staff
  • ****
  • I'm NOT back!
    • The IKB Forum
Re: ACM Module intensity problem
« Reply #2 on: 17 Aug 2009, 10:27:46 »
Your solution works JamesF1. Thanks. There's still a small chance that enemy units might pop up and ruin the opening scene, but now 99.9% of the users will never notice that
 :whistle:
OFPEC | Intel Depot
RETARDED Ooops... Retired!