Welcome, Guest Thursday 17th April 2014, 20:15:13
   Home   Help Search Login Register  

OFPEC Forum

Author Topic: waypoint problem ?bug? (behaviour-safe)  (Read 934 times)
0 Members and 1 Guest are viewing this topic.
h-
Forum
Administrator
*****
Offline Offline


Formerly HateR_Kint


WWW
« Reply #15 on: 17 May 2007, 08:13:02 »

Quote
And doesnt matter the behaviour set in next waypoint, they'll never return to safe
At least in version 1.05 this was not true.

Yes, the group will not change it's behavior immediately to what the waypoint tells them, it takes time, but they did change their behaviour eventually..

Encountered this while writing a random patrol script (which I never finished because someone else wrote a better one..)
Logged

Project MCAR   ---   FWW2 - Finland At War 1939-1945
INFORMATIVE THREAD TITLES PLEASE. "PLEASE HELP" IS NOT ONE..
Chuck Norris can divide by zero.
Mr.Peanut
Former Staff
****
Offline Offline

urp!


« Reply #16 on: 17 May 2007, 15:19:49 »

Quote
..., but they did change their behaviour eventually..
How long was eventually? Does this mean the 1.06 patch is bugged or not?

Quote
(which I never finished because someone else wrote a better one..)

Don't you just fucking hate that? It makes your life suddenly easier, but causes shrinkage.
Logged

urp!
Mandoble
Editors Depot
Administrator
*****
Offline Offline



WWW
« Reply #17 on: 17 May 2007, 17:00:39 »

the problem is there, in 1.07 beta, so I assume the problem is also in US 1.06. I did wait several minutes (case where the troops moved on after detecting and killing the enemy) and they never switched to safe again. They were just moving between two waypoints, both with "SAFE" in behaviour box. But in the first test, my firing in front of them and they being unable to find any enemy nearby, they simply never moved and this was tested in both 1.05 and 1.07 beta.
Logged

h-
Forum
Administrator
*****
Offline Offline


Formerly HateR_Kint


WWW
« Reply #18 on: 17 May 2007, 20:46:04 »

Quote
How long was eventually?
Never measured it but it was fairly long..
Of course this doesn't mean it's not a bug, it seems that something overrides the waypoint orders..

Quote
But in the first test, my firing in front of them and they being unable to find any enemy nearby, they simply never moved and this was tested in both 1.05 and 1.07 beta.
I can confirm this on the 1.05 part as well.
But, it happened quite rarely, I would say once or twice out of like 50.. Don't Know

EDIT:
Ok, just tested the time it took the group to return to "safe" (in a situation discussed) and it took approx. 3 minutes..
Until that the group followed it's waypoints but in combat or aware mode (didn't test which, probably aware because they didn't crawl or go prone constantly)..
« Last Edit: 17 May 2007, 21:11:38 by h- » Logged

Project MCAR   ---   FWW2 - Finland At War 1939-1945
INFORMATIVE THREAD TITLES PLEASE. "PLEASE HELP" IS NOT ONE..
Chuck Norris can divide by zero.
dematti
*
Offline Offline


« Reply #19 on: 20 May 2007, 03:36:30 »

was out few days but found a solution for my problem now
simply by making 2 triggers wich will set them to combat when enemy is near and another one to safe when they are gone.
Although this doesnt solve the problem
But, it happened quite rarely, I would say once or twice out of like 50.. Don't Know
happened every time to me (1.05) they just hold position forever (maybe until they see enemy wich will make them go combat behaviour)
its a bug for sure and needs to be reported.
Logged
Pages: 1 [2]  All   Go Up
  Send this topicPrint  
 
Jump to: